Questions » Recent Q&A » Android, iOS apps working normally without upgrading to GD SDK v6.0.1

Android, iOS apps working normally without upgrading to GD SDK v6.0.1

Posted 10 days ago
  • We don't recommend using GD SDK 4.2 on iOS 12 or Android 9 due to data leakage issues introducted by OS changes that are fixed in the 5.x SDK.

    Regarding the newer releases...

    For iOS 13, apps build using XCode 11 will not be able to interoperate with BlackBerry Dynamics apps that are using a BlackBerry Dynamics SDK below 6.1.x.  If all apps on the device are built with XCode 10 or lower and using BlackBerry Dynamics SDK 6.0.x and lower they can interoperate.  Unless you are using purely internally built applications on your device, this configuration willl not be possible as we and our ISV Partners release application updates.

    For Android 10, apps built using a BlackBerry Dynamics SDK lower than 6.0.x will have issues with AppKinetics (BlackBerry Dynamics Shared Serivces.  Attempting to use them on Android 10 with an SDK lower than 6.0.x will result in an erro message..

Back